forum.math.uoa.gr

Forum του Τμήματος Μαθηματικών
Ημερομηνία 20 Νοέμ 2017, 02:02

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]




Δημιουργία νέου θέματος Απάντηση στο θέμα  [ 12 δημοσιεύσεις ] 
Συγγραφέας Μήνυμα
 Θέμα δημοσίευσης: Ελληνικά σε Latex
ΔημοσίευσηΔημοσιεύτηκε: 08 Δεκ 2012, 09:41 
Χωρίς σύνδεση
Regular Forumer

Εγγραφη: 26 Σεπ 2009, 00:58
Δημοσ.: 517
Τοποθεσια: Πειραιάς
Γεια σας. Είναι η πρώτη φορά που γράφω σε λατεχ και έχω κάποια προβλήματα. μπορεί να μου πει καποιος πως να γράψω ελλνικά σε λατεχ; εχω δκιμάσει διάφορες εντολές στην αρχή του κειμένου που βρηκα στο νετ και το καλύτερο που κατάφερα είναι να μου βγουν "κινέζικα". Χρησιμοποιώ τον tex maker.
Τι εντολές βάζετε εσεις για ελληνικά;


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Ελληνικά σε Latex
ΔημοσίευσηΔημοσιεύτηκε: 08 Δεκ 2012, 10:20 
Χωρίς σύνδεση
Regular Forumer

Εγγραφη: 26 Σεπ 2009, 00:58
Δημοσ.: 517
Τοποθεσια: Πειραιάς
βρηκα κατι αλλα προμοια θεματα εδω και δοκιμασα τις εντολες που ελεγαν αλλα μου βγαζει error οτι θα πρέπει να αλλάξω την typesetting engine μου σε xelatex, κατι που δεν ξέρω αν το εχω κανει. εχω αλλάξει την επιλογή στο πεδίο που αρχικά ελεγε "γρηγορη μεταγλωττιση" σε "xelatex" αλλα μαλλον δεν ειναι αυτό γιατί το προβλημα παραμενει..


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Ελληνικά σε Latex
ΔημοσίευσηΔημοσιεύτηκε: 08 Δεκ 2012, 10:46 
Χωρίς σύνδεση

Εγγραφη: 22 Μάιος 2012, 18:24
Δημοσ.: 81
Δοκίμασε να γράψεις αυτό
Κώδικας:
\documentclass[12pt]{article}
\usepackage[english,greek]{babel}
\usepackage[iso-8859-7]{inputenc}
\usepackage{a4}
\usepackage{amsfonts}
\usepackage{amssymb}
\begin{document}
Καλημέρα.
\latintext
This is a new day.
\greektext
Ποιος είναι ο αριθμός \textlatin{Erd\"os} σου?
\end{document}

και να κάνεις μεταγλώττιση όχι με xelatex αλλά με pdflatex (ή δοκίμασε και τη γρήγορη μεταγλώττιση αν σου δούλευε πριν).


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Ελληνικά σε Latex
ΔημοσίευσηΔημοσιεύτηκε: 08 Δεκ 2012, 10:51 
Χωρίς σύνδεση
Regular Forumer

Εγγραφη: 26 Σεπ 2009, 00:58
Δημοσ.: 517
Τοποθεσια: Πειραιάς
το καλό είνα οτι πλέον δε μου βγάζει το προηγομενο error. το κακό είναι ότι
πάλι τα ελληνικά βγαίνουν με κεφαλαια Ξ, Ο και γενικά ακαταλλαβιστικους συνδυασμους :/


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Ελληνικά σε Latex
ΔημοσίευσηΔημοσιεύτηκε: 08 Δεκ 2012, 11:11 
Χωρίς σύνδεση

Εγγραφη: 22 Μάιος 2012, 18:24
Δημοσ.: 81
Δοκίμασε το εξής:
Στον TeX maker επέλεξε Options -> Configure Texmaker -> Editor
και στο encoding επέλεξε το ISO-8859-7.
Άνοιξε ένα ΚΑΙΝΟΥΡΙΟ αρχείο, ξαναγράψε τα ίδια με πριν και κάνε μεταγλώττιση.


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Ελληνικά σε Latex
ΔημοσίευσηΔημοσιεύτηκε: 08 Δεκ 2012, 11:23 
Χωρίς σύνδεση

Εγγραφη: 22 Μάιος 2012, 18:24
Δημοσ.: 81
Εναλλακτικά επέλεξε ως encoding το UTF-8 αλλά στον κώδικα της LaTeX που σου έγραψα πιο πάνω αντικατέστησε το
Κώδικας:
\usepackage[iso-8859-7]{inputenc}
με το
Κώδικας:
\usepackage[utf8x]{inputenc}


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Ελληνικά σε Latex
ΔημοσίευσηΔημοσιεύτηκε: 08 Δεκ 2012, 11:31 
Χωρίς σύνδεση
Regular Forumer

Εγγραφη: 26 Σεπ 2009, 00:58
Δημοσ.: 517
Τοποθεσια: Πειραιάς
ουαου. βγηκε. σ ευχαριστω παρα πολυ!! :happy:


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Ελληνικά σε Latex
ΔημοσίευσηΔημοσιεύτηκε: 10 Ιαν 2013, 21:41 
Χωρίς σύνδεση
Regular Forumer
Άβαταρ μέλους

Εγγραφη: 25 Σεπ 2007, 17:31
Δημοσ.: 4235
Έχει κανείς πρόβλημα με το
\usepackage[iso-8859-7]{inputenc}
στο texnicenter τόσα χρόνια έτρεχε τώρα όχι;;;;;;;;;;;
Με τα χίλια ζόρια έκανε install το \usepackage[utf8x]{inputenc} το οποίο στο milktex 8 δεν το κατάλάβαινε

Και κάτι γιαα όποιον τυραννιέται
Spoiler:
Παράθεση:
και γενικά τρώει κολλήματα ειδικά αυτό το https://lh6.googleusercontent.com/-5LH_ ... 640/gr.JPG
μας έχει ζαλίσει,το οποίο αντιμετωπίζεται πηγαίνοντας Alt+F7
Λατεχ-->πδφ και κάνουμε τα δύο πρώτα command line argument και βάζουμε για εντολή "%bm.pdf"



Τόσα χρόνια λάτεχ συνέχεια δε ξέρεις τι θα σου βγάλει κάθε φορά :patpat:

_________________
https://www.youtube.com/watch?v=wbZuBDJVHEI


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Ελληνικά σε Latex
ΔημοσίευσηΔημοσιεύτηκε: 10 Ιαν 2013, 22:50 
Χωρίς σύνδεση
Regular Forumer
Άβαταρ μέλους

Εγγραφη: 04 Φεβ 2011, 03:20
Δημοσ.: 760
Τοποθεσια: Math Labs
Kαι σε μένα έβγαζε πρόβλημα το \usepackage[iso-8859-7]{inputenc}
Γιατί δεν χρησιμοποιείς Xetex και Texmaker? :P

_________________
A journey of a thousand miles begins with a single step.


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Ελληνικά σε Latex
ΔημοσίευσηΔημοσιεύτηκε: 10 Ιαν 2013, 23:25 
Χωρίς σύνδεση
Regular Forumer
Άβαταρ μέλους

Εγγραφη: 25 Σεπ 2007, 17:31
Δημοσ.: 4235
Το Texmaker παρόμοια σφάλματα βγάζει σε γενικές γραμμές,το Xetex είναι σαν άλλο milktex;;
Θα το δοκιμάσω άμα είναι κι αυτό να δούμε :p

Γενικά το texnicenter μου δουλεύει αλλά κάθε λιγο και λιγάκι όλο και κάτι θα βγάλει και τώρα αυτό
το οποίο λύνεται αλλά γιατί δε δουλεύει όπως παλιά;
Και σε όποιον υπολ/στη το βάζω κατά καιρούς δικό μου ή άλλων πάντα κάποιο λάθος θα βγάλει

_________________
https://www.youtube.com/watch?v=wbZuBDJVHEI


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Ελληνικά σε Latex
ΔημοσίευσηΔημοσιεύτηκε: 11 Ιαν 2013, 00:35 
Χωρίς σύνδεση
Regular Forumer
Άβαταρ μέλους

Εγγραφη: 18 Μαρ 2006, 00:26
Δημοσ.: 302
Τοποθεσια: Κερατσίνι
barney έγραψε:
Το Texmaker παρόμοια σφάλματα βγάζει σε γενικές γραμμές,το Xetex είναι σαν άλλο milktex;;
Θα το δοκιμάσω άμα είναι κι αυτό να δούμε :p

Γενικά το texnicenter μου δουλεύει αλλά κάθε λιγο και λιγάκι όλο και κάτι θα βγάλει και τώρα αυτό
το οποίο λύνεται αλλά γιατί δε δουλεύει όπως παλιά;
Και σε όποιον υπολ/στη το βάζω κατά καιρούς δικό μου ή άλλων πάντα κάποιο λάθος θα βγάλει


Δοκίμασε το texstudio.

_________________
Ζήσε τα μαθηματικά σου!


Κορυφή
 Προφίλ  
 
 Θέμα δημοσίευσης: Re: Ελληνικά σε Latex
ΔημοσίευσηΔημοσιεύτηκε: 12 Ιαν 2013, 10:05 
Χωρίς σύνδεση
Regular Forumer
Άβαταρ μέλους

Εγγραφη: 25 Σεπ 2007, 17:31
Δημοσ.: 4235
Επειδή το texnicenter το δουλεύω ξερω γω πόσα χρόνια,(αλλά κάθε φορά που γίνεται φορμάτ ο υπολογιστής μετά θέλει πολύ ώρα για στρώσιμο),για αυτό ρωτάω για την εντολή,δλδ δε θέλω να τ'αλλάξω
Απ'ότι κατάλαβα υπάρχει κάποιο θέμα με την εντολή η οποία μάλλον πρέπει να την αντικαταστήσω με την utf8x που δουλεύει μόνο στο μιλτεχ9.0.

_________________
https://www.youtube.com/watch?v=wbZuBDJVHEI


Κορυφή
 Προφίλ  
 
Τελευταίες δημοσιεύσεις:  Ταξινόμηση κατά  
Δημιουργία νέου θέματος Απάντηση στο θέμα  [ 12 δημοσιεύσεις ] 

Όλοι οι χρόνοι είναι UTC + 2 ώρες [ DST ]


Μελη σε συνδεση

Μέλη σε αυτή την Δ. Συζήτηση : Δεν υπάρχουν εγγεγραμμένα μέλη και 1 επισκέπτης


Δεν μπορείτε να δημοσιεύετε νέα θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να απαντάτε σε θέματα σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να επεξεργάζεστε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση
Δεν μπορείτε να διαγράφετε τις δημοσιεύσεις σας σε αυτή τη Δ. Συζήτηση

Αναζήτηση για:
Μετάβαση σε:  
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group